Twitter Facebook

Jump to content



For Support/complaints mail to support@router-ie.com

For Data center questions: Datacenter-IE.com & DC-IE.com & CCIEDatacenter-IE.com
For Routing and Switching questions: Router-IE.com & CCIERNS-IE.com
For Security questions: Security-IE.com & CCIESecurity-IE.com
For Wireless questions: Wireless-IE.com & CCIEWireless-IE.com
For Service Provider questions: ServiceProvider-IE.com & SP-IE.com & CCIEServiceProvider-IE.com
For Collaboration-IE questions : CollaborationIE.com & CCIECollaboration-IE.com
For CCDE-IE questions - CCDE-IE.com
For JUNIPER-IE questions : JUNIPER-IE.com & JUNIPERIE.com


Photo

LAB 2 -- NEXUS 1000v


  • Please log in to reply
15 replies to this topic

#1 superx

superx

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • 660 thanks

Section 4. Data Center Virtualization

 

4.1. Manual pinning configuration VSM

 

port-profile type ethernet vm-data

  vmware port-group server-data

  switchport mode access

  switchport access vlan 70

  channel-group auto mode on sub-group manual

  no shutdown

  state enabled

 

 

interface Ethernet3/2

  inherit port-profile vm-data

  sub-group-id 1

 

4.2. Port profile presented name to vCenter VSM

 

port-profile type vethernet vlan 50

  vmware port-group dmz

 

4.3. iSCSI port-profile configuration

 

port-profile type vethernet ISCSI

  switchport mode access

  switchport access vlan 30

  capability iscsi-multipath

  no shutdown

  system vlan 30

  state enabled

 

4.4. iSCSI port-profile QoS configuration

 

policy-map type qos ISCSI

 class class-default

  set  cos  2

!

port-profile type vethernet ISCSI

 service-policy type qos output ISCSI


  • mdm23_2005 and ccielearner2015 like this

#2 superx

superx

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
  • 660 thanks

If anyone has any doubt or what to do discussion can surely reply on the post so that we can get 100% of it!



#3 mdm23_2005

mdm23_2005

    Advanced Member

  • Members
  • PipPipPip
  • 42 posts
  • 11 thanks

thanks buddy !!



#4 rex

rex

    Newbie

  • Members
  • Pip
  • 2 posts
  • 9 thanks
4.4
 
policy-map type qos mark-silver
class class-default
set cos 2
 
We have to only mark COS 2 to iscsi packets in VSM cli .No need to make "class-default" as it is default and available . See if "Policy-map" is available with cos - 2 , if available just apply this particular policy to a Veth Port-Profile (Iscsi) as shown below -: else do step 1 and 2 both.
 
2. port-profile type vethernet VMS
vmware port-group
switchport mode access
switchport access vlan 1
pinning id 2
service-policy type qos input mark-silver
no shutdown
system vlan 1
state enabled
 
port-profile type vethernet iscsi
service-policy type qos input mark-silver
 
interface port-channel 3
service-policy type qos input mark-silver
policy-map type qos alltraffic
class class-default
set cos 2
 
port-profile type vethernet iscsi
service-policy type qos input alltraffic
interface port-channel 3
service-policy type qos input alltraffic


#5 shawn80

shawn80

    Newbie

  • Members
  • Pip
  • 2 posts
  • 33 thanks

which one is correct

 

1)

port-profile type vethernet ISCSI

 service-policy type qos output ISCSI

 

or

 

2)

port-profile type vethernet iscsi
service-policy type qos input mark-silver


#6 kaos

kaos

    Newbie

  • Members
  • Pip
  • 6 posts
  • 2 thanks

no. 2 is correct . 



#7 epuara

epuara

    Advanced Member

  • Members
  • PipPipPip
  • 63 posts
  • 13 thanks

Rex, could you please explain your solution. It doesn't make a lot of sense.



#8 epuara

epuara

    Advanced Member

  • Members
  • PipPipPip
  • 63 posts
  • 13 thanks

I believe the "channel-group auto mode on sub-group manual" should be placed in the type ethernet port-profile (the uplink), not in the vethernet one.



#9 luvincanada

luvincanada

    Newbie

  • Members
  • Pip
  • 7 posts
  • 0 thanks

I have doubt on  Ethernet uplink profile.   If it is Ethernet uplink, shouldn't it be "trunk" mode  instead of access..?

 

 

 

port-profile type Ethernet vmdata

VMware port-group server-data

switchport mode trunk

switchport trunk allowed vlan 30,40,70 >>>

system vlan 30,70  >>>

channel-group auto mode on sub-group-id manual

no shut

state enabled

 

 

Is this understanding correct , that we should have trunk mode on uplink than access mode?



#10 nerdbird11

nerdbird11

    Member

  • Members
  • PipPip
  • 22 posts
  • 5 thanks

The question clearly states the uplink profile which would be the ethernet profile and yes it would be a trunk. 

 

shawn80 - you would use the input for marking the iscsi 



#11 Kalle

Kalle

    Member

  • Members
  • PipPip
  • 11 posts
  • 1 thanks

On question 4.1 how do you know which vmnic is connected to which ethernetport?

 

the question states:

"...

For e.g vmnic1 = subgroup ID 1, vmnic2 = subgroup ID 2 and so on.

"

 

Nevermind i found it in this post: http://www.datacente...virtual-switch/



#12 Kalle

Kalle

    Member

  • Members
  • PipPip
  • 11 posts
  • 1 thanks

Section 4. Data Center Virtualization

 

4.1. Manual pinning configuration VSM

 

port-profile type ethernet vm-data

  vmware port-group server-data

  switchport mode access

  switchport access vlan 70

  channel-group auto mode on sub-group manual

  no shutdown

  state enabled

 

 

interface Ethernet3/2

  inherit port-profile vm-data

  sub-group-id 1

 

4.2. Port profile presented name to vCenter VSM

 

port-profile type vethernet vlan 50

  vmware port-group dmz

 

4.3. iSCSI port-profile configuration

 

port-profile type vethernet ISCSI

  switchport mode access

  switchport access vlan 30

  capability iscsi-multipath

  no shutdown

  system vlan 30

  state enabled

 

4.4. iSCSI port-profile QoS configuration

 

policy-map type qos ISCSI

 class class-default

  set  cos  2

!

port-profile type vethernet ISCSI

 service-policy type qos output ISCSI

I did all this except input on the service-policy on 4.4 and only got a 50% on the lab.

 

Could someone help me understand mhy?

 

Regards



#13 blowme

blowme

    Newbie

  • Members
  • Pip
  • 6 posts
  • 0 thanks

So I'm wondering about the sub-groups. I don't think you only configure channel-group auto mode on manual sub-group on the eth profile and then put the sub-groups on modules 3 and 4 uplinks  (and make sure those uplinks have the inherit port-profile commands on them - default?)... I think you also have to apply sub-groups to veth port-profiles that go to vmnics correct? A networkers preso mentioned this but didn't have the slide for it (the presenter was wondering what happened to that slide).



#14 blowme

blowme

    Newbie

  • Members
  • Pip
  • 6 posts
  • 0 thanks

I think i found my answer: http://www.cisco.com....html#wp1301735



#15 blowme

blowme

    Newbie

  • Members
  • Pip
  • 6 posts
  • 0 thanks

Kalle, how did that link answer your question? That shows you what physical links modules 3 and 4 use. Not what vmnics use.



#16 Kalle

Kalle

    Member

  • Members
  • PipPip
  • 11 posts
  • 1 thanks


IF you execute the command module vem x execute vemcmd show port you will see which vmnic is connected to which eth if




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users